$re = '/^(?!.*[.!]"?$).*$/m';
$str = 'say "bye"
say "bye
say "bye.
say "bye!
say "bye."
say "bye!"
hey look this is the line not ending with period
oh this looks cool. . . . . but should not match .
say bye"
say bye".
say bye"!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);