#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)`[^`]*`|\{@link\s+([^}\s|]+)(?:\s*\|?\s*([^}]*))*?\s*\}"
Local $sString = "'Simple link: {@link BIND/bindExec} test'," & @CRLF & _
"'description: {@link fooFunction description text}'," & @CRLF & _
"'pipe: {@link spaced | test}'," & @CRLF & _
"'ignored:`{@link IGNORE}` in code sample. {@link allowed} `not {@link IGNORE2} here`'," & @CRLF & _
"'unspaced pipe: {@link unspaced|test}'," & @CRLF & _
"'accidental pipe: {@link damaged1| }'," & @CRLF & _
"'unspaced accidental pipe: {@link damaged2|}'," & @CRLF & _
"'Multiple links: {@link foo} and {@link bar description} and {@link baz | text}'," & @CRLF & _
"'Complex: {@link module:path/to/thing~method } {@link Class#method some text} {@link external:jQuery.fn.prop} text {@link adafa|fasdfsaf}'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")