const regex = /`[^`]*`|\{@link\s+([^}\s|]+)(?:\s*\|?\s*([^}]*))*?\s*\}/ug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('`[^`]*`|\\{@link\\s+([^}\\s|]+)(?:\\s*\\|?\\s*([^}]*))*?\\s*\\}', 'ug')
const str = `'Simple link: {@link BIND/bindExec} test',
'description: {@link fooFunction description text}',
'pipe: {@link spaced | test}',
'ignored:\`{@link IGNORE}\` in code sample. {@link allowed} \`not {@link IGNORE2} here\`',
'unspaced pipe: {@link unspaced|test}',
'accidental pipe: {@link damaged1| }',
'unspaced accidental pipe: {@link damaged2|}',
'Multiple links: {@link foo} and {@link bar description} and {@link baz | text}',
'Complex: {@link module:path/to/thing~method } {@link Class#method some text} {@link external:jQuery.fn.prop} text {@link adafa|fasdfsaf}'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}