import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"`[^`]*`|\{@link\s+([^}\s|]+)(?:\s*\|?\s*([^}]*))*?\s*\}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
'Simple link: {@link BIND/bindExec} test',
'description: {@link fooFunction description text}',
'pipe: {@link spaced | test}',
'ignored:`{@link IGNORE}` in code sample. {@link allowed} `not {@link IGNORE2} here`',
'unspaced pipe: {@link unspaced|test}',
'accidental pipe: {@link damaged1| }',
'unspaced accidental pipe: {@link damaged2|}',
'Multiple links: {@link foo} and {@link bar description} and {@link baz | text}',
'Complex: {@link module:path/to/thing~method } {@link Class#method some text} {@link external:jQuery.fn.prop} text {@link adafa|fasdfsaf}'
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)