using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"`[^`]*`|\{@link\s+([^}\s|]+)(?:\s*\|?\s*([^}]*))*?\s*\}";
string input = @"'Simple link: {@link BIND/bindExec} test',
'description: {@link fooFunction description text}',
'pipe: {@link spaced | test}',
'ignored:`{@link IGNORE}` in code sample. {@link allowed} `not {@link IGNORE2} here`',
'unspaced pipe: {@link unspaced|test}',
'accidental pipe: {@link damaged1| }',
'unspaced accidental pipe: {@link damaged2|}',
'Multiple links: {@link foo} and {@link bar description} and {@link baz | text}',
'Complex: {@link module:path/to/thing~method } {@link Class#method some text} {@link external:jQuery.fn.prop} text {@link adafa|fasdfsaf}'";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}