import re
regex = re.compile(r"`[^`]*`|\{@link\s+([^}\s|]+)(?:\s*\|?\s*([^}]*))*?\s*\}", flags=re.UNICODE)
test_str = ("'Simple link: {@link BIND/bindExec} test',\n"
"'description: {@link fooFunction description text}',\n"
"'pipe: {@link spaced | test}',\n"
"'ignored:`{@link IGNORE}` in code sample. {@link allowed} `not {@link IGNORE2} here`',\n"
"'unspaced pipe: {@link unspaced|test}',\n"
"'accidental pipe: {@link damaged1| }',\n"
"'unspaced accidental pipe: {@link damaged2|}',\n"
"'Multiple links: {@link foo} and {@link bar description} and {@link baz | text}',\n"
"'Complex: {@link module:path/to/thing~method } {@link Class#method some text} {@link external:jQuery.fn.prop} text {@link adafa|fasdfsaf}'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")