package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)]d2[01]{2}(\d{14})(?:10|17|21)(\w+)\[GS\](\w+)(?:10|17|21)(\w+)`)
var str = `]d2010704626096200210KT0BT2204[GS]1726090021RNM5F8CTMMBHZSY7
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}