$re = '/]d2[01]{2}(\d{14})(?:10|17|21)(\w+)\[GS\](\w+)(?:10|17|21)(\w+)/m';
$str = ']d2010704626096200210KT0BT2204[GS]1726090021RNM5F8CTMMBHZSY7
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);