const regex = new RegExp(']d2[01]{2}(\\d{14})(?:10|17|21)(\\w+)\\[GS\\](\\w+)(?:10|17|21)(\\w+)', 'gm')
const str = `]d2010704626096200210KT0BT2204[GS]1726090021RNM5F8CTMMBHZSY7
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}