re = /]d2[01]{2}(\d{14})(?:10|17|21)(\w+)\[GS\](\w+)(?:10|17|21)(\w+)/m
str = ']d2010704626096200210KT0BT2204[GS]1726090021RNM5F8CTMMBHZSY7
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end