import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "]d2[01]{2}(\\d{14})(?:10|17|21)(\\w+)\\[GS\\](\\w+)(?:10|17|21)(\\w+)";
final String string = "]d2010704626096200210KT0BT2204[GS]1726090021RNM5F8CTMMBHZSY7\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}