#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/?(?!system/)(?:[-\w]+/)*(?:index\.php|)(?:\?[-&=\w]+|)$"
Local $sString = "/abc/" & @CRLF & _
"//abc/" & @CRLF & _
"abc/" & @CRLF & _
"abc/abc/" & @CRLF & _
"/abc/index.php?utm_source=vk" & @CRLF & _
"/abc/abc/index.php?utm_source=vk" & @CRLF & _
"/systemsssss/abc/index.php?utm_source=vk" & @CRLF & _
"/system/sssss/abc/index.php?utm_source=vk" & @CRLF & _
"system/sssss/abc/index.php?utm_source=vk" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")