re = /^\/?(?!system\/)(?:[-\w]+\/)*(?:index\.php|)(?:\?[-&=\w]+|)$/m
str = '/abc/
//abc/
abc/
abc/abc/
/abc/index.php?utm_source=vk
/abc/abc/index.php?utm_source=vk
/systemsssss/abc/index.php?utm_source=vk
/system/sssss/abc/index.php?utm_source=vk
system/sssss/abc/index.php?utm_source=vk
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end