$re = '~^/?(?!system/)(?:[-\w]+/)*(?:index\.php|)(?:\?[-&=\w]+|)$~m';
$str = '/abc/
//abc/
abc/
abc/abc/
/abc/index.php?utm_source=vk
/abc/abc/index.php?utm_source=vk
/systemsssss/abc/index.php?utm_source=vk
/system/sssss/abc/index.php?utm_source=vk
system/sssss/abc/index.php?utm_source=vk
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);