const regex = new RegExp('^/?(?!system/)(?:[-\\w]+/)*(?:index\\.php|)(?:\\?[-&=\\w]+|)$', 'gm')
const str = `/abc/
//abc/
abc/
abc/abc/
/abc/index.php?utm_source=vk
/abc/abc/index.php?utm_source=vk
/systemsssss/abc/index.php?utm_source=vk
/system/sssss/abc/index.php?utm_source=vk
system/sssss/abc/index.php?utm_source=vk
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}