import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/?(?!system/)(?:[-\\w]+/)*(?:index\\.php|)(?:\\?[-&=\\w]+|)$";
final String string = "/abc/\n"
+ "//abc/\n"
+ "abc/\n"
+ "abc/abc/\n"
+ "/abc/index.php?utm_source=vk\n"
+ "/abc/abc/index.php?utm_source=vk\n"
+ "/systemsssss/abc/index.php?utm_source=vk\n"
+ "/system/sssss/abc/index.php?utm_source=vk\n"
+ "system/sssss/abc/index.php?utm_source=vk\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}