using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*:([0-9]{12}):.*";
string input = @"arn:aws:kinesis:us-west-2:033814027111:stream/my_event_stream";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}