re = /.*:([0-9]{12}):.*/
str = 'arn:aws:kinesis:us-west-2:033814027111:stream/my_event_stream'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end