// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*:([0-9]{12}):.*").unwrap();
let string = "arn:aws:kinesis:us-west-2:033814027111:stream/my_event_stream";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}