$re = '/.*:([0-9]{12}):.*/';
$str = 'arn:aws:kinesis:us-west-2:033814027111:stream/my_event_stream';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);