package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*:([0-9]{12}):.*`)
var str = `arn:aws:kinesis:us-west-2:033814027111:stream/my_event_stream`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}