#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(\d{2}|RF)\d{9}\b"
Local $sString = "RF123456789" & @CRLF & _
"RF12345678989" & @CRLF & _
"RF1234567898" & @CRLF & _
"RF123456789" & @CRLF & _
"aaaa RF123456789 sef " & @CRLF & _
"11123456789"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")