package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\d{2}|RF)\d{9}\b`)
var str = `RF123456789
RF12345678989
RF1234567898
RF123456789
aaaa RF123456789 sef
11123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}