re = /\b(\d{2}|RF)\d{9}\b/m
str = 'RF123456789
RF12345678989
RF1234567898
RF123456789
aaaa RF123456789 sef
11123456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end