$re = '/\b(\d{2}|RF)\d{9}\b/m';
$str = 'RF123456789
RF12345678989
RF1234567898
RF123456789
aaaa RF123456789 sef
11123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);