// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\d{2}|RF)\d{9}\b").unwrap();
let string = "RF123456789
RF12345678989
RF1234567898
RF123456789
aaaa RF123456789 sef
11123456789";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}