use strict;
my $str = 'The door swung open to reveal pink giraffes and red elephants.
He stomped on his fruit loops and thus became a cereal killer.
Lightning Paradise was the local hangout joint where the .
a
sd
a
He didn’t want to go to the dentist, yet he went anyway.
He decided to count all the sand on the beach as a hobby.
* Situps are a terrible way to end your day.
The random sentence generator generated a random sentence about a random sentence.
As time wore on, .
The beach was crowded with snow leopards.
She was too short to see over the fence.
';
my $regex = qr/^[\ \t]*(\S?(?:.*\S)?)?[\ \t]*$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}