import re
regex = re.compile(r"^[\ \t]*(\S?(?:.*\S)?)?[\ \t]*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("The door swung open to reveal pink giraffes and red elephants. \n"
" He stomped on his fruit loops and thus became a cereal killer.\n"
" Lightning Paradise was the local hangout joint where the .\n"
" \n"
" \n"
"a\n"
"sd\n"
"a \n\n"
"He didn’t want to go to the dentist, yet he went anyway. \n"
"He decided to count all the sand on the beach as a hobby. \n"
" \n\n"
"* Situps are a terrible way to end your day. \n"
"The random sentence generator generated a random sentence about a random sentence.\n"
"As time wore on, . \n"
" The beach was crowded with snow leopards. \n"
" \n"
"She was too short to see over the fence.\n\n"
" \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")