import Foundation
let pattern = #"^[\ \t]*(\S?(?:.*\S)?)?[\ \t]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
The door swung open to reveal pink giraffes and red elephants.
He stomped on his fruit loops and thus became a cereal killer.
Lightning Paradise was the local hangout joint where the .
a
sd
a
He didn’t want to go to the dentist, yet he went anyway.
He decided to count all the sand on the beach as a hobby.
* Situps are a terrible way to end your day.
The random sentence generator generated a random sentence about a random sentence.
As time wore on, .
The beach was crowded with snow leopards.
She was too short to see over the fence.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)