re = /^[\ \t]*(\S?(?:.*\S)?)?[\ \t]*$/mi
str = 'The door swung open to reveal pink giraffes and red elephants.
He stomped on his fruit loops and thus became a cereal killer.
Lightning Paradise was the local hangout joint where the .
a
sd
a
He didn’t want to go to the dentist, yet he went anyway.
He decided to count all the sand on the beach as a hobby.
* Situps are a terrible way to end your day.
The random sentence generator generated a random sentence about a random sentence.
As time wore on, .
The beach was crowded with snow leopards.
She was too short to see over the fence.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end