// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^[\ \t]*(\S?(?:.*\S)?)?[\ \t]*$").unwrap();
let string = "The door swung open to reveal pink giraffes and red elephants.
He stomped on his fruit loops and thus became a cereal killer.
Lightning Paradise was the local hangout joint where the .
a
sd
a
He didn’t want to go to the dentist, yet he went anyway.
He decided to count all the sand on the beach as a hobby.
* Situps are a terrible way to end your day.
The random sentence generator generated a random sentence about a random sentence.
As time wore on, .
The beach was crowded with snow leopards.
She was too short to see over the fence.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}