using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\n.*)""[^""]*"",";
string input = @"""abc
de
f 123"",123,456
""asdf
ghj
kl"",789,100
""asdfghjkl"",000,900";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}