re = /^(?=.*\n.*)"[^"]*",/m
str = '"abc
de
f 123",123,456
"asdf
ghj
kl",789,100
"asdfghjkl",000,900'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end