$re = '/^(?=.*\n.*)"[^"]*",/m';
$str = '"abc
de
f 123",123,456
"asdf
ghj
kl",789,100
"asdfghjkl",000,900';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);