import re
regex = re.compile(r"^(?=.*\n.*)\"[^\"]*\",", flags=re.MULTILINE)
test_str = ("\"abc\n\n"
"de\n"
"f 123\",123,456\n"
"\"asdf\n"
"ghj\n\n"
"kl\",789,100\n"
"\"asdfghjkl\",000,900")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")