# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\w\|)[a-f0-9]+(?:-[a-f0-9]+)+\b/$2/gm;t' <<< "Germany|fbf4cf3c-ebfe-43c8-aaf9-6811bd3488b0"