use strict;
my $str = 'Germany|fbf4cf3c-ebfe-43c8-aaf9-6811bd3488b0';
my $regex = qr/(?<=\w\|)[a-f0-9]+(?:-[a-f0-9]+)+\b/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";