$re = '/(?<=\w\|)[a-f0-9]+(?:-[a-f0-9]+)+\b/m';
$str = 'Germany|fbf4cf3c-ebfe-43c8-aaf9-6811bd3488b0';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;