#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\w\|)[a-f0-9]+(?:-[a-f0-9]+)+\b"
Local $sString = "Germany|fbf4cf3c-ebfe-43c8-aaf9-6811bd3488b0"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)