using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\w\|)[a-f0-9]+(?:-[a-f0-9]+)+\b";
string substitution = @"$2";
string input = @"Germany|fbf4cf3c-ebfe-43c8-aaf9-6811bd3488b0";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}