# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\d{1,2})\s*:\s*(\d{1,2})\s*([ap])\.\s*m\./$1:$2 $3m/gm;t' <<< "2:0 a. m.
2:0 p. m.
3:0 p. m.
3:0p.m.
2:0 am"