$re = '/\b(\d{1,2})\s*:\s*(\d{1,2})\s*([ap])\.\s*m\./m';
$str = '2:0 a. m.
2:0 p. m.
3:0 p. m.
3:0p.m.
2:0 am';
$subst = "$1:$2 $3m";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;