re = /\b(\d{1,2})\s*:\s*(\d{1,2})\s*([ap])\.\s*m\./m
str = '2:0 a. m.
2:0 p. m.
3:0 p. m.
3:0p.m.
2:0 am'
subst = '$1:$2 $3m'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result