// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\d{1,2})\s*:\s*(\d{1,2})\s*([ap])\.\s*m\.").unwrap();
let string = "2:0 a. m.
2:0 p. m.
3:0 p. m.
3:0p.m.
2:0 am";
let substitution = "$1:$2 $3m";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}