import re
regex = re.compile(r"\b(\d{1,2})\s*:\s*(\d{1,2})\s*([ap])\.\s*m\.", flags=re.MULTILINE)
test_str = ("2:0 a. m.\n"
"2:0 p. m.\n"
"3:0 p. m.\n"
"3:0p.m.\n\n"
"2:0 am")
subst = "$1:$2 $3m"
result = regex.sub(subst, test_str)
if result:
print(result)