#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?<!^)\[.*?\]"
Local $sString = "[" & @CRLF & _
" [1, "flowchart TD\nid>This is a flag shaped node]"]," & @CRLF & _
" [2, "flowchart TD\nid(((This is a double circle node)))"]," & @CRLF & _
" [3, "flowchart TD\nid((This is a circular node))"]," & @CRLF & _
" [4, "flowchart TD\nid>This is a flag shaped node]"]," & @CRLF & _
" [5, "flowchart TD\nid{'This is a rhombus node'}"]," & @CRLF & _
" [6, 'flowchart TD\nid((This is a circular node))']," & @CRLF & _
" [7, 'flowchart TD\nid>This is a flag shaped node]']," & @CRLF & _
" [8, 'flowchart TD\nid{"This is a rhombus node"}']," & @CRLF & _
" [9, """" & @CRLF & _
" flowchart TD" & @CRLF & _
" id{"This is a rhombus node"}" & @CRLF & _
" """]," & @CRLF & _
" [10, 'xxxxx']," & @CRLF & _
" ]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")