$re = '/(?<!^)\[.*?\]/ms';
$str = '[
[1, "flowchart TD\\nid>This is a flag shaped node]"],
[2, "flowchart TD\\nid(((This is a double circle node)))"],
[3, "flowchart TD\\nid((This is a circular node))"],
[4, "flowchart TD\\nid>This is a flag shaped node]"],
[5, "flowchart TD\\nid{\'This is a rhombus node\'}"],
[6, \'flowchart TD\\nid((This is a circular node))\'],
[7, \'flowchart TD\\nid>This is a flag shaped node]\'],
[8, \'flowchart TD\\nid{"This is a rhombus node"}\'],
[9, """
flowchart TD
id{"This is a rhombus node"}
"""],
[10, \'xxxxx\'],
]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);