import Foundation
let pattern = #"(?<!^)\[.*?\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
[
[1, "flowchart TD\nid>This is a flag shaped node]"],
[2, "flowchart TD\nid(((This is a double circle node)))"],
[3, "flowchart TD\nid((This is a circular node))"],
[4, "flowchart TD\nid>This is a flag shaped node]"],
[5, "flowchart TD\nid{'This is a rhombus node'}"],
[6, 'flowchart TD\nid((This is a circular node))'],
[7, 'flowchart TD\nid>This is a flag shaped node]'],
[8, 'flowchart TD\nid{"This is a rhombus node"}'],
[9, """
flowchart TD
id{"This is a rhombus node"}
"""],
[10, 'xxxxx'],
]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)