use strict;
my $str = '[
[1, "flowchart TD\\nid>This is a flag shaped node]"],
[2, "flowchart TD\\nid(((This is a double circle node)))"],
[3, "flowchart TD\\nid((This is a circular node))"],
[4, "flowchart TD\\nid>This is a flag shaped node]"],
[5, "flowchart TD\\nid{\'This is a rhombus node\'}"],
[6, \'flowchart TD\\nid((This is a circular node))\'],
[7, \'flowchart TD\\nid>This is a flag shaped node]\'],
[8, \'flowchart TD\\nid{"This is a rhombus node"}\'],
[9, """
flowchart TD
id{"This is a rhombus node"}
"""],
[10, \'xxxxx\'],
]';
my $regex = qr/(?<!^)\[.*?\]/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}