# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!^)\[.*?\]"
test_str = ("[\n"
" [1, \"flowchart TD\\nid>This is a flag shaped node]\"],\n"
" [2, \"flowchart TD\\nid(((This is a double circle node)))\"],\n"
" [3, \"flowchart TD\\nid((This is a circular node))\"],\n"
" [4, \"flowchart TD\\nid>This is a flag shaped node]\"],\n"
" [5, \"flowchart TD\\nid{'This is a rhombus node'}\"],\n"
" [6, 'flowchart TD\\nid((This is a circular node))'],\n"
" [7, 'flowchart TD\\nid>This is a flag shaped node]'],\n"
" [8, 'flowchart TD\\nid{\"This is a rhombus node\"}'],\n"
" [9, \"\"\"\n"
" flowchart TD\n"
" id{\"This is a rhombus node\"}\n"
" \"\"\"],\n"
" [10, 'xxxxx'],\n"
" ]")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.